Service Request Time Out Error
Incident Report for fcawitech
Resolved
This incident has been resolved.
Posted Jun 14, 2023 - 11:58 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 14, 2023 - 04:01 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 13, 2023 - 20:03 UTC
Identified
The issue has been identified as a global Amazon AWS Server outage. Amazon is aware of the issue and working towards resolving.
Posted Jun 13, 2023 - 20:00 UTC
Investigating
Good Afternoon wiTECH Users,

Currently, you may be experiencing problems loading Flashes, RSUs, Recalls, NVPs, and more.
Our technical staff is aware of this concern, and they are working towards a resolution.
Posted Jun 13, 2023 - 19:40 UTC
This incident affected: Stellantis ICT Webservices.