wiTECH Performance Issues

Incident Report for fcawitech

Resolved

This incident has been resolved.
Posted Sep 16, 2026 - 12:40 UTC

Update

Corrections have been made by our technical staff concern this issue. And, the issue has been Resolved.
Posted Sep 16, 2026 - 12:38 UTC

Monitoring

A fix has been implemented and we are monitoring the results. Internal testing shows SGW unlocking as it should now.
Posted Sep 15, 2026 - 22:55 UTC

Investigating

Good Afternoon wiTECH Users,

Some of you may be experiencing issues with the wiTECH Application unlocking the SGW. This will affect Flashes, Actuators and Routines.

Our technical staff is aware of this concern and they are working towards a resolution.

Please check back at this site for updates.
Posted Sep 15, 2026 - 20:17 UTC
This incident affected: Stellantis ICT Webservices and ECU Flash.