wiTECH website is failing to load
Incident Report for fcawitech
Resolved
wiTECH is performing well. The issue has been resolved.
Posted Jan 05, 2024 - 15:14 UTC
Monitoring
The issue has been identified and fixed. We are currently monitoring the wiTECH site performance.
Posted Jan 05, 2024 - 14:48 UTC
Investigating
You may be experiencing issues or slowness in loading the wiTECH website. We are currently investigating this issue.
Posted Jan 05, 2024 - 14:30 UTC
This incident affected: wiTECH Cloud Server.